Back to overview
Resolved

Service disruption resolved following a failed hosting-provider migration

Jul 10, 2026 at 5:27am UTC
Affected services
trekmail.net
TrekMail Dashboard
TrekMail Webmail

Resolved
Jul 10, 2026 at 5:27am UTC

Resolved: All TrekMail services have been fully operational since 07:14 CEST on July 10.

A planned infrastructure migration by our hosting provider failed overnight, causing a service disruption from 00:22 to 07:14 CEST. We restored the platform from backups and confirmed that all services are operating normally.

Messages sent during the outage were queued by external mail servers and delivered after recovery.

A limited number of messages received shortly before the incident may be unavailable in some mailboxes. Messages already downloaded to email applications should remain available locally. We are contacting affected customers directly and continuing recovery efforts with the provider.

We have completed a fresh backup and are implementing additional safeguards to prevent similar incidents.

Questions: support@trekmail.net