Back to overview
Resolved

Infrastructure partner outage affecting TrekMail services

Aug 21, 2026 at 8:24pm UTC
Affected services
trekmail.net
TrekMail Dashboard
TrekMail Webmail

Resolved
Aug 21, 2026 at 8:24pm UTC

One of our infrastructure partners is currently experiencing a host-system incident affecting the infrastructure used by TrekMail.

As a result, the TrekMail website, Dashboard, Webmail, and email services may currently be unavailable or intermittently inaccessible.

The issue has been confirmed on our infrastructure partner's side, and their technical team is actively working on recovery. We are monitoring the situation closely and will restore full service as soon as the affected infrastructure becomes available.

There is currently no confirmed ETA for resolution. We will publish additional updates as soon as new information becomes available.

For assistance, please contact support@trekmail.net.